"Error occurred connecting to database" when connecting FYI Desktop Practice Sync app

Issue

When trying to connect the FYI Practice Sync Desktop app, the following message is displayed:

  • "Error occurred connecting to database ...:"

2096_Migrate_Error_occured_connecting_to_Database.gif

Cause

This is caused by either of the following:

  • SQL not allowing remote connections to the server, 
  • the firewall not containing an exception for the port that SQL is using, or 
  • TCP/IP is disabled.

Resolution

  1. Ensure the user account you are logged into the FYI app is the same account used to run the FYI Practice Sync Desktop app.
  2. Confirm that the correct server and database name have been selected in FYI Practice Sync Desktop app.
  3. Check that the SQL Server Service is running in SQL Server Configuration Manager.
  4. Enabled TCP/IP in SQL Server Configuration Manager.
  5. Ensure the SQL database is configured to accept remote connections then restart the instance.
  6. Create an exception on the firewall for the SQL Server instance and port that is being used.
Was this article helpful?
0 out of 0 found this helpful

Stay Up-To-Date

  • Events

    We host a range of product demos, training webinars, workshops and more.

  • Service Status

    Check for updates on the FYI Platform

  • What's New

    Round-up of new features, fixes, and other important announcements.