Issue
When trying to connect the FYI Practice Sync Desktop app, the following message is displayed:
- "Error occurred connecting to database ...:"
Cause
This is caused by either of the following:
- SQL not allowing remote connections to the server,
- the firewall not containing an exception for the port that SQL is using, or
- TCP/IP is disabled.
Resolution
- Ensure the user account you are logged into the FYI app is the same account used to run the FYI Practice Sync Desktop app.
- Confirm that the correct server and database name have been selected in FYI Practice Sync Desktop app.
- Check that the SQL Server Service is running in SQL Server Configuration Manager.
- Enabled TCP/IP in SQL Server Configuration Manager.
- Ensure the SQL database is configured to accept remote connections then restart the instance.
- Create an exception on the firewall for the SQL Server instance and port that is being used.