Documents created from Templates and Stationery have incorrect formatting

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Issue

The formatting of documents created from Templates and/or Stationery within FYI results in unnecessary line breaks, incorrect inconsistent fonts or incorrect font sizes.

Cause

The incorrect formatting of documents could be caused by one of the following scenarios:

  • A Word Page, Section or Column Break in the Template is causing the Stationery to not be picked up
  • Template includes a Table created with a Word Table Style
  • Template is generated with Letterhead that forces a style
  • Table cell has an HTML property forcing the text to cut off
  • Headers and/or footers are in both the Template and the Stationery
  • A Word Page Break is causing an Additional Page to be added
  • Image file format (SVG) does not display when creating a document
  • Image disappears when converted to a PDF

Refer to the Solutions below for more information and how to resolve each issue.

Solution

Click on the relevant cause below, for details on the associated solution.

A Word Page, Section or Column Break in the Template is causing the Stationery to not be picked up

If you have any Word Section Breaks in the Template, this can cause a Stationery to not work as expected or to not getting picked up. This can also be an issue with Page or Column breaks. This is actually a limitation from Microsoft and is beyond FYI's control.

Solution

Delete any Page, Section or Column breaks from your template for the stationery to work as expected.

Template includes a Table created with a Word Table Style

When using a Stationery with a Template that has been created using the Word Table Style feature, this may give incorrect formatting such as incorrect fonts.

Solution

  1. In the template, highlight the table you want to update.
  2. Click the Word menu Table Design.
  3. Locate the option Plain Tables and select Table Grid to apply this to the table.
Template is generated with Letterhead that forces a style

When creating a document from a Template that also uses a Letterhead, if the Template doesn't specifically have formatting applied, the Letterhead may force styling that's different from the Template, for example, the font used in a table.

Solution

  1. Edit the Template.
  2. Right-click Normal from the Styles tab.
  3. Click Modify.
  4. Select the desired font.
  5. Save the changes.
  6. In FYI, click Finish Editing to synchronise the template changes.
Table cell has an HTML property forcing the text to cut off

If your table is breaking text across the line incorrectly, rather than starting a new line with the whole word, it can be caused by an HTML property on the cell. For example, the first table has the HTML property "word-break" while the second one doesn't.

Notice the difference in the words at the end of each line.

2707_Task_Template_Table_Line_Break_Word_Wrap.gif

Solution

To resolve the issue, click the <> icon to view the HTML code.

Search the code for the property "word-break:break-all;" and remove it (ensure you remove the semi-colon after it, and no other characters).

Example:

<td style="width: 100.0000%;word-break:break-all;">

After being removed:

<td style="width: 100.0000%;">

Click the <> icon again to view the HTML preview and confirm the issue has been resolved.

Headers and/or footers are in both the Template and the Stationery

If you are using headers and/or footers, these need to be added to either Templates or to the Stationery, not both. If these are in both, this can cause the Stationery to not work as expected.

Solution
Remove the header and footer from either the Template or Stationery.

A Word Page Break is causing an Additional Page to be added

If you have a Page break in a Word Template or Stationery, this will add a page break to the document that is created.

Solution
Remove the Word Page Break in the Template or Stationery.

Image file format (SVG) does not display when creating a document

If an image inserted into a Template or Stationery is saved as an SVG file, the image may not display when creating a document.

Solution

Replace the SVG image file with a JPEG (.jpg) image, reinsert it, then click Finish Editing in FYI.

Image disappears when converted to a PDF

This issue is caused by the way Microsoft handles graphics when converted to PDF, and can occur when converting a document to PDF through an Automation step in FYI, or manually when saving the document to a PDF file on the computer.

We recommend avoiding copying and pasting into Word, as it can be the cause of this issue.

Solution

You will need to save the image, and then re-add it to the document as a picture.

To insert a picture, select Insert > Pictures > This Device, and then Save Changes.

We recommend following the steps above with images in a different format (typically .png or .jpg) to find one that works when creating a document is from the template and converting it to a PDF.

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