Error "Oh no, we had a problem creating your document." when sharing documents using New Collaborate

Plan: Not Available: Intermediate Available: Pro or Elite

Users: Not Available: All users, User Group Permissions Available: FYI Admins

Practice Management Source: Available: All sources

Issue

When sharing documents using New Collaborate, including Share No Email, the following error is displayed:

  • Oh no, we had a problem creating your document.

Note: For errors related to when creating an email (unrelated to New Collaborate) refer to "Error creating document. Oh no, we had a problem creating your document" or "Cannot carry out your request" when creating a document.

Cause

This error is typically caused when the SharePoint site was created manually, rather than using the FYI Collaborate wizard, and there are configuration issues with the SharePoint permissions or the site itself.

Solution

Step 1 - Run the New Collaborate Status Check

The status check to run will depend on the Collaborate Site Type selected for the client in FYI:

Run the Client Collaborate Status Check or Client Secured Collaborate General Status Check and click "Fix" for any identified errors. Refer to Checking your New Collaborate Status.

  • The New Client Collaborate Status Check can be accessed via Automations - Apps - "Collaborate - Client".
  • The Client Secured Collaborate General Status Check can be accessed from the Client - Collaborate tab.

Step 2 - Check the SharePoint Site Guest User Configuration

You should review your Guest User configuration to ensure documents can be shared with users correctly. For example, any restrictions or policies that may be in place.

Refer to Setting up Microsoft 365 for New Collaborate.

Step 3 - Confirm the OneDrive Admin is the Owner of the SharePoint site

  1. Open the Microsoft 365 Admin Center by visiting https://admin.microsoft.com/.
     
  2. Log in using a Microsoft Global Admin account.
     
  3. From the menu on the left-hand side, locate the Admin Centers section and select SharePoint (you may need to first click Show All). 
     
  4. From the menu on the left-hand side, click Sites > Active Sites.
     
  5. Select the site in the list.
     
  6. Click the Membership tab.
     
  7. Click the Site Owners tab on the left.
    3218_New_Collaborate_Admin_Centre_Site_Owner.gif
     
  8. If the OneDrive Admin isn't an owner, click + Add site owners.
     
  9. Enter the name or email address of the user, and select the user from the drop-down list.
     
  10. Click Add.
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