Issue
When trying to open an Office document from FYI, for example, an Excel spreadsheet, an error similar to the following appears:
- Protocolhandler.exe - System Error: The code execution cannot process because (filename) DLL was not found. Reinstalling the program may fix this problem.
Cause
The issue appears to be caused by a configuration issue with specific versions of Office.
While you resolve the issue, documents can be opened online in the interim by selecting Edit via browser or using the FYI Desktop App (recommended approach). Refer to FYI Desktop App and Opening, Editing and Finish Editing Documents.
Note: You can set the default for how you want to open documents in your profile. Refer to Setting Defaults and Filing Defaults for your own Login - My Settings.
Solution
You will need to perform a full uninstallation and reinstallation of all Office products on the impacted machine.
The error may reoccur once more before the Office programs begin to function correctly. Should the error persist, your IT Administrators may need to contact Microsoft directly for assistance.