Error FYI-2235: Error updating job state - Change to state not accepted by XPM

Plan: Available: All plans 

Users: Available: All users

Practice Management Source: Available: All sources

Issue

For practices integrated with Xero Practice Manager, when updating a job in FYI, the following message is displayed in Practice Activity:

  • Error updating job state - Change to state not accepted by XPM

Cause

When a job is cancelled, the WIP in Xero Practice Manager is archived. While the WIP is pending, FYI will not be able to update the Job State.

Solution

To resolve the issue, you will need to do one of the following:

  • Remove the outstanding time entries in XPM and perform a manual Job sync from Xero Practice Manager before updating the Job State in FYI. Refer to Running a Manual Sync with Xero Practice Manager.
     
  • Change the Job Type to "Standard" and retry the sync from FYI.
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