Issue
For practices integrated with Xero Practice Manager, when updating a job in FYI, the following message is displayed in Practice Activity:
- Error updating job state - Change to state not accepted by XPM
Cause
When a job is cancelled, the WIP in Xero Practice Manager is archived. While the WIP is pending, FYI will not be able to update the Job State.
Solution
To resolve the issue, you will need to do one of the following:
- Remove the outstanding time entries in XPM and perform a manual Job sync from Xero Practice Manager before updating the Job State in FYI. Refer to Manual Sync in Synchronising Clients, Staff, Jobs, Time, Tax Returns with Xero Practice Manager.
- Change the Job Type to be "Standard" and retry the sync from FYI.
You should also consider changing the Xero Practice Manager app setting Maintain Jobs In FYI to "Yes". When enabled, changes to Jobs are only made in FYI, and not synchronised to Xero Practice Manager.