Plan: Available: All plans
Users: Available: All users
Practice Management Source: Not Available: APS, Iris, MYOB AE & AO, CCH, MYOB Practice Management (formerly GreatSoft) Available: FYI or Xero Practice Manager
Issue
A Manager or Partner has been assigned to a job in Xero Practice Manager but when Xero Practice Manager syncs with FYI, the Manager/Partner is set to "Unassigned". Practice Activity shows one of the following errors:
- "Unable to assign job to users. Invalid staff identifier for manager assignment."
- "Unable to assign job to users. Invalid staff identifier for partner assignment."
- "Unable to assign job to users. Invalid staff identifier for add request."
Cause
The FYI user account that shows as the Manager or Partner is linked to an account in Xero Practice Manager that has been deleted. FYI cannot update the Manager or Partner, and Xero Practice Manager cannot be updated as the user no longer exists.
Solution
The Job in Xero Practice Manager will need to be updated, along with any Automations in FYI referencing that particular user. Refer to Automation Process Steps.