Plan: Not Available: Intermediate Available: Pro or Elite
Users: Not Available: All users Available: FYI Admins or User Group permissions
Practice Management Source: Available: All sources
Issue
Testing or running a CSV Data Import displays the error "Invalid Data" with the following reason:
- JobNumber is not a valid Job Number (Multiple matching clients)
Cause
When importing data using CSV Data Import with Filter Type set to JobNumber, any leading zeroes in the CSV file column will be removed during the import. This can cause the import to find multiple matching jobs and clients, resulting in the displayed error message.
For example, there may be two jobs in FYI, one job with the Job Number 012345, and another job with the Job Number 12345. This can occur when jobs have been created from different practice management platforms, resulting in inconsistent job number formats. When the CSV file is imported, 012345 will be converted to 12345, and will match both jobs and associated clients.
Solution
To resolve the issue, users must use the Look Up Job step to find a matching job in FYI, rather than matching jobs using the Automation Filter.
To match jobs, users must add the Look Up Job step to the automation process.
The Look Up Job step will also remove leading zeroes, so users must configure the additional filters to narrow the results and find the matching job. For example, users can search by Job Type, Job Name, or Custom Fields.
Ensure that when adding the Look Up Job step, the following fields are configured exactly as below, to prevent the automation from performing incorrectly or inadvertently creating new jobs.
| Field | Details |
| If Job Not Found |
Must be set to Stop Process. This ensures the automation does not continue without a relevant job or create new jobs incorrectly. |
| Context Behaviour |
Must be set to Update context to lookup result. This instructs the automation to treat this job as the trigger job for the automation. |
The Look Up Job step must be repositioned as the first step in the automation to ensure that any subsequent steps are applied to the correct job.
To reorder the steps, click and drag the Move icon in the first column, and drag the step to the new location.
For any remaining steps in the automation, users must update any relevant fields to ensure the Job located in the Look Up Job step is used. Use the Job Merge Field in the Step 1 Job section.
Update the Automation Filter to remove job matching.
- Change the Filter Type for the JobNumber column to String.
- Untick Match Jobs During Validation.
This prevents the invalid Job Number error from being displayed and allows the import to proceed.
Users can now test the automation to confirm the error has been resolved before proceeding to run the Automation Process.