Plan: Not Available: Intermediate Available: Pro or Elite
Users: Not Available: All users Available: FYI Admins or User Group permissions
Practice Management Source: Available: All sources
Issue
When running an automation containing an Execute Process step, the automation completes successfully but a warning message is displayed in Process History:
- Attempted to execute process (process name), but no executions were started due to (process name) configuration.
Cause
This warning occurs when the top level process attempts to start the Execute Process step, but no records match the execute process filter configuration.
This could be due to one of the following:
- Apply Additional Process Filter is enabled on the Execute Process step. When the step runs, the executing process does not meet the same filter criteria.
- The process being executed has Run Once Per Job enabled and has already processed that job in a previous execution step. Because the job no long meets the criteria, no new execution is started.
Solution
The executing process should be reviewed to determine why it was not run:
- If Apply Additional Process Filter was enabled, review the executing process to ensure that it meets the same filter criteria.
- If Run Once Per Job is enabled in the executing process step, confirm that the automation has not already run for that job.
Users can run the executing process manually, however it should be considered whether running again may cause duplicate data. Refer to Process History and Activity.