Error "XPM sync skipped: Custom Field has a value greater than 2,147,483,647".

Plan: Available: All plans

Users: Not Available: All users Available: FYI Admins or User Group permissions

Practice Management Source: Available: All sources

Issue

When synchronising Custom Field updates from FYI to Xero Practice Manager, one of the following errors are displayed in Practice Activity:

  • “XPM sync skipped: Job custom field '{FieldName}' has a value greater than 2,147,483,647. Update the value and try again.”
  • “XPM sync skipped: Client custom field '{FieldName}' has a value greater than 2,147,483,647. Update the value and try again.”

Cause

Xero Practice Manager (XPM) does not support numeric values greater than 2,147,483,647 for Client or Job fields.

When a value exceeds this limit, FYI skips synchronising the Custom Field and continues processing the remaining updates.

Solution

If an Automation Process is updating the field with a value above the XPM limit, update the Automation Process to use a smaller number.

To update the Custom Field for a client or job: 

  1. Click on the error in Practice Activity to display the Drawer.
     
  2. Click on the link in the Drawer to the affected client or job.
     
  3. Navigate to the Custom Fields tab.
     
  4. Update the Custom Field value to a number less than 2,147,483,647.
     
  5. Click Save

The Custom Field will be updated during the next sync with XPM.

Was this article helpful?
0 out of 0 found this helpful

Stay Up-To-Date

  • Events

    We host a range of product demos, training webinars, workshops and more.

  • Service Status

    Check for updates on the FYI Platform

  • What's New

    Round-up of new features, fixes, and other important announcements.