Plan: Available: All plans
Users: Not Available: All users Available: FYI Admins or User Group Permissions
Practice Management Source: Not Available: APS, Iris, MYOB AE & AO, CCH, MYOB Practice Management (formerly GreatSoft) Available: FYI or Xero Practice Manager
Issue
When FYI attempts to create a job in Xero Practice Manager (XPM), the request may fail because the Xero Practice Manager API rate limit has been exceeded. The following messages will be displayed in Practice Activity:
- Error creating job in XPM - Too many requests.
- Failed to create (x) number of jobs due to XPM rate limiting. Jobs will be retried when rates are available.
Cause
This issue occurs when the Xero Practice Manager API rate limits have been exceeded. For more information on the limits that apply to Xero Practice Manager, refer to Xero Practice Manager Rate Limits.
Solution
No manual action is required.
FYI will automatically retry creating the affected job during the next manual or overnight synchronisation with Xero Practice Manager (XPM) once rates become available.
If the rate limit is exceeded again during the retry, the job will remain pending, and will be retried during the next synchronisation.