Job State reverted and XPM Error "Job cannot be cancelled as it has unbilled Work In Progress."

Plan: Available: All plans

Users: Available: All users

Practice Management Source: Not Available: APS, Iris, MYOB AE & AO, CCH, MYOB Practice Management (formerly GreatSoft) Available: FYI or Xero Practice Manager

Issue

In FYI, I updated the State of a Job to "Cancelled". But after the sync has occurred, the State is reverted back to its previous State.

Cause

In Xero Practice Manager, the Job could not be cancelled due to unbilled Work in Progress. The State was never updated in Xero Practice Manager.

In Xero Practice Manager, this would show the following message:

  • Job cannot be cancelled as it has unbilled Work In Progress. You can use the Remove from Invoice List button on the Financial tab to clear this WIP.

When Job States are synced to Xero Practice Manager, if the State cannot be changed in Xero Practice Manager for any reason, this is reported in Practice Activity (refer to Practice Activity).

Solution

As per the message, in Xero Practice Manager, use the Remove from Invoice List button on the Financial tab to clear the Work in Progress.

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