Error "Cannot find matching Client for Contact" when synchronising Clients

Plan: Available: All plans

Users: Not Available: All users Available: FYI Admins or User Group permissions

Practice Management Source: Not Available: FYI, Xero Practice Manager, APS, IRIS, MYOB AE & AO, CCH Central, MYOB Practice Management (formerly GreatSoft) Available: No PM Source

Issue

When synchronising clients via Practice Sync, the following error is displayed in Practice Activity:

  • Cannot find matching client for Contact

Cause

This error occurs when a Contact record cannot be matched to a Client during the Practice Sync process. FYI relies on a unique combination of Client Name and Source ID to correctly map Contacts to Clients.

If this combination cannot be found, the Contact cannot be linked, and an error is displayed to alert the practice.

Solution

You will need to update the contact in your integrated practice management platform to exactly match the client name.

Tip: The impacted Client Name and Client Code will be displayed, to assist with troubleshooting.

During the next scheduled synchronisation, Practice Sync will attempt to sync the client again.

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