When creating or editing a Form Template, the message "Need admin approval" displays

Issue

When creating or editing a Form Template, the below message displays:

  • Need admin approval

Cause

This message displays when the Syntaq application, used to create Forms, does not have the required permissions granted by a Microsoft 365 Administrator in Microsoft Entra. Form templates cannot be created or edited until a Microsoft 365 admin grants approval.

Solution

To resolve this issue, a Microsoft 365 admin must approve the required permissions for the app.  Microsoft 365 admin will need to grant permission by:

  1. Select "Have an admin account? Sign in with that account" when the message displays.
     
  2.  Sign in with the Microsoft 365 admin account.
     
  3. Ensure that "Consent on behalf of the organisation" is ticked.

If the "Need Admin approval" message continues to display, your IT provider will need to review Microsoft's recent User Consent settings changes and determine whether the "Allow user consent for apps from verified publishers, for selected permissions" setting in Entra can be used.

If the issue continues, we recommend contacting Microsoft Support for further assistance, as FYI do not control tenant policies and settings.

 

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