Plan: Not Available: Intermediate, Pro Available: Elite
Users: Not Available: All users Available:FYI Admins or User Group Permissions
Practice Management Source: Not Available: APS, Iris, MYOB AE & AO, CCH, MYOB Practice Management (formerly GreatSoft) Available: FYI or Xero Practice Manager
Issue
When refreshing a report using the FYI Add-in in Excel, the following error displays:
- "Error running report: Excel is in cell-editing mode. Please exit the edit mode by pressing ENTER or TAB, or selecting another cell, and then try again"
Cause
This occurs when Excel is in cell-editing mode while the report is refreshing. For example, if you click into a different cell to edit it or interact with another open spreadsheet during the refresh, Excel prevents the Add-in from completing the refresh.
Note: FYI does not control this behaviour as this is a limitation of Microsoft 365. It is recommended that users avoid interacting with Excel when refreshing a report.
Solution
- In the Excel report, press Enter or Tab on your keyboard, or select another cell to exit cell-editing mode.
- Click Refresh Report Data on the report again.
- Wait until the report has finished refreshing before editing cells or switching to another open spreadsheet.