Plan: Not Available: Intermediate, Pro Available: Elite
Users: Not Available: All users Available:FYI Admins or User Group Permissions
Practice Management Source: Not Available: APS, Iris, MYOB AE & AO, CCH, MYOB Practice Management (formerly GreatSoft) Available: FYI or Xero Practice Manager
Issue
When refreshing a report, the following error message is displayed:
- "Error running report: There was an internal error while processing the request"
Cause
The report has become unresponsive during the refresh process due to filters applied in the report's Data tab.
Solution
To resolve this issue, remove any filters from the Data tab:
- Open the report and navigate to the Data tab.
- Remove any applied filters.
- Click Refresh Report Data in the FYI drawer. Refer to Opening, Editing and Finishing Editing Reports.
Once the report has refreshed successfully, apply filtering using the pivot table on the Report tab. Filtering within the pivot table allows the report to refresh correctly while still displaying the required data.