Plan: Available: All plans
Users: Not Available: All users Available: FYI Admins or User Group Permissions
Practice Management Source: Not Available: MYOB AE & AO, FYI, APS, IRIS, CCH, MYOB Practice Management (formerly GreatSoft) Available: Xero Practice Manager
Issue
Custom User Role values are missing or being cleared in Xero Practice Manager (XPM) after synchronising with FYI.
Cause
Custom User Roles are maintained in FYI only and sync to XPM as text fields. If the corresponding Custom User Role field in XPM is changed to another field type (for example, drop-down), FYI cannot recognise this change. As FYI cannot recognise the field type, the value is blank in FYI, and the corresponding values in XPM may be cleared.
Solution
There are two options to resolve this issue:
- Recreate the Custom User Role as a text field (Recommended)
- Manage Users with a drop-down custom field
Recreate the Custom User Role as a text field (Recommended)
- In XPM, delete the existing Custom Field configured as a drop-down.
- Recreate the Custom Field using the same name and set the field type to Text.
- In FYI, ensure the correct user is assigned to the Custom User Role for each relevant Client or Job.
- Upon the next sync, FYI will update compatible values back to XPM.
Note: If the field was previously changed to a drop-down in XPM, FYI cannot restore those values. Practices may wish to contact XPM support to request an export of historical values before making changes.
Manage Users with a drop-down custom field
Important: For practices that choose to manage users with a drop-down field, the Custom User Role will no longer be a User type field in FYI, and functionality (for example, assigning tasks or workflow) can no longer be used.
- Change the Custom Field type in FYI from User to Drop-down.
- Manage and maintain the field values using drop-down custom fields.
- Manually reselect values for existing Clients or Jobs as required.