Error "The JavaScript API requested failed" displays when refreshing Report Data

Plan: Not Available: Intermediate, Pro Available: Elite

Users: Not Available: All users Available:FYI Admins or User Group Permissions

Practice Management Source: Not Available: APS, Iris, MYOB AE & AO, CCH, MYOB Practice Management (formerly GreatSoft) Available: FYI or Xero Practice Manager

Issue

When attempting to refresh an FYI Report in Excel, the following error message is displayed:

  • "Error running report: The JavaScript API request failed due to the lack of support for the undo operation."

Cause

This error occurs when the installed version of Excel does not support the required JavaScript API for FYI Reports, due to an outdated Excel version.

Solution

Users will need to contact their IT Admin to confirm they are using the most recent version of Excel. If the version is not the latest, your IT team will need to update Microsoft 365 Excel to the latest version.

Once updated, reopen the report and refresh the report.

Was this article helpful?
0 out of 0 found this helpful

Stay Up-To-Date

  • Events

    We host a range of product demos, training webinars, workshops and more.

  • Service Status

    Check for updates on the FYI Platform

  • What's New

    Round-up of new features, fixes, and other important announcements.