Plan: Not Available: Intermediate, Pro Available: Elite
Users: Not Available: All users Available:FYI Admins or User Group Permissions
Practice Management Source: Not Available: APS, Iris, MYOB AE & AO, CCH, MYOB Practice Management (formerly GreatSoft) Available: FYI or Xero Practice Manager
Issue
When opening a Form Template, the Form Builder window displays one of the following warning messages:
- Warning: The following fields are no longer available in your account.
These fields may have been removed from your account or you may no longer have access to them. Forms using these fields may not function correctly until they are removed or replaced.
- Warning: The following issues were detected with FYI fields.
Fields with type mismatches or that are missing may cause forms to malfunction. Please update or remove these fields from your form.
Each warning lists the fields that are affected.
Cause
The Form Template includes Custom Fields that no longer exist or where the Custom Field ID no longer matches due to a change in the custom field. This can occur when:
- A Form Template uses Custom Fields that have not been created or have since been deleted in FYI. For example, importing a Sample Template that contains a custom field that has not been created in your platform.
- A Custom Field was deleted and later recreated, resulting in a new ID.
- A Custom field Type has been edited. For example, changed from String to Number.
Solution
Review the warning message and note each listed Custom Field name and ID. Follow the steps below to resolve the issue.
The Form Template includes Custom Fields that have not been created in your platform. For example, importing a Sample Template that contains a custom field that has not been created in your platform.
- In FYI, click the Settings menu and select Practice Settings.
- Select Custom Fields and review the list of existing fields.
- Create new Custom Fields matching the names displayed in the warning message.
- Return to the Form Builder and reopen the Form Template to confirm the issue is resolved.
A previously deleted Custom Field has been recreated, but its ID differs from the original reference in the Form Template.
- Note the field names shown in the warning message in the Form Builder.
- In FYI, navigate to Settings - Practice Settings - Custom Fields and confirm the field exists.
- If present, remove the missing field reference in the Form Builder and select the correct Custom Field from the drop-down list.
- Save the Form Template.
Note: Even if a Custom Field has the same name, it will still trigger an error if the ID differs.
The Form Template includes Custom Fields that have been edited in FYI. For example, a Custom Field that originally had a drop-down but has been changed to a text field.
- In FYI, click the Settings menu and select Practice Settings.
- Select Custom Fields and review the list of existing fields.
- Return to the Form Template - Form Builder window and remove the custom field from the form.
- Select the correct Custom Field from the drop-down list.
- Save the Form Template.