Issue
For practices integrated with MYOB, APS, CCH or IRIS using Practice Sync, the following error is displayed in Practice Activity:
- Sync failed with error: Exception of type 'System.OutOfMemoryException' was thrown
Cause
This error occurs when the server running the FYI Practice Sync experiences a memory issue while processing the sync. Queries used by the sync process handle large pieces of data, and at that time, the server did not have a memory block large enough to complete the process, resulting in a temporary error.
Solution
While the FYI Practice Sync app logs this error, it will attempt to process the request during subsequent syncs. If this error appears frequently, we recommend increasing the available RAM on the server running FYI Practice Sync.