Plan: Not Available: Intermediate, Pro Available: Elite
Users: Not Available: All users Available: FYI Admins or User Group permissions
Practice Management Source: Not Available: Xero Practice Manager, APS, Iris, MYOB AE & AO, CCH, MYOB Practice Management (formerly GreatSoft) Available: FYI
Issue
When a Progress or Final invoice is created from a Create Invoice process step, the invoice may fail to sync to Xero. The following sync exception error is displayed in Practice Activity:
- Error exporting Invoice - Missing Invoice Items. Please add Selected Jobs to the invoice.
Cause
This error occurs when the Job associated with the invoice contains no Work in Progress (WIP) at the time the invoice is created. Without WIP, the invoice has no items to include when syncing to Xero, resulting in the error message.
Solution
To prevent this error, ensure that the Job has WIP before creating a progress or final invoice.
This ensures that there is billable time included in the invoice, allowing the sync to Xero to complete successfully.
For more information on configuring automation steps, refer to Process Step Details - Create Invoice.