Business Structure appearing in filter list after being removed from XPM

Plan: Available: All plans

Users: Available: All users

Practice Management Source: Not Available: MYOB AE & AO, FYI, APS, IRIS, CCH, MYOB Practice Management (formerly GreatSoft) Available: Xero Practice Manager

Issue

For practices integrated with Xero Practice Manager (XPM), when updating a Client, Business Structures continue to appear in the Business Structure filter even after they have been removed or no longer in use in XPM.

Cause

Business Structures appear in filter lists when they are still assigned to one or more clients. This includes both active and archived clients. If any client remains linked to that Business Structure, it will continue to show as an available option in the filter list.

Solution

To remove a Business Structure from appearing in your filter lists, users need to ensure that it is not assigned to any clients (active or archived):

  1. Temporarily assign the Business Structure to an active client. This ensures it appears as an option in your list.
     
  2. Filter a Client view to:
    • Status column to Archived.
    • Business Structure column to locate all clients currently using that structure.
       
  3. Run a Bulk Update to change those clients to a different, suitable Business Structure.
     
  4. Select the correct business structure used by the client in Step 1.

Once no clients are assigned to the deleted Business Structure, it will no longer appear in the filter list.

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