Issue
When synchronising Custom Fields with Xero Practice Manager, the following error is displayed in Practice Activity:
- A Custom Field was renamed due to changes in XPM.
Cause
This issue occurs when a Custom Field has been synchronised from XPM, but the name is already used for a different Custom Field in FYI.
Solution
FYI will automatically rename the new field to append _1 to resolve the conflict and allow the Custom Field to be synchronised successfully. If _1 has already been used, FYI will use the next available number.
To prevent this issue from occurring in the future, it's recommended to maintain Custom Fields in FYI, including renaming and deleting Custom Fields. Refer to the articles in the Custom Fields section of the Help Centre.