Process Filter CSV Data Import - Error Report

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When importing data into FYI using a Custom Process with the CSV Data Import filter selected, FYI will first validate the data. If errors are found, an Error Report will be created to allow the user to correct and import the data.

4327_CSV_Import_Error_Report_CSV.gif

CSV Data Import Error Report

The CSV Data Import Error Report will be created when testing or running the process. The report can be downloaded using the link available from:

Testing and Running a Custom Process

If errors are detected, a message will be displayed on the Test or Run window:

  • Executions will not be created for (number) rows containing invalid data.

Click the link to download the Error Report. The Error Report will also be filed in FYI, refer to Filing Details in FYI below.

4096_CSV_Data_Import_Run_Window.gif

Note: if you continue to run the automation process, the process will be displayed in Automation History as "Success", as the process was still executed even though not all data could be imported. 

Practice Activity

To view the Error Report:

  1. Click on the Failure in Practice Activity to display the Activity drawer.
     
  2. Click the Details heading to expand the section.
     
  3. Click the View issue report CSV link. The Error Report will also be filed in FYI, refer to Filing Details in FYI below.
    3465_CSV_Data_Import_Issue_Report_Link.gif
  4. You will be redirected to the document, which will display a preview of the invalid data and the reason for failure. 
    3466_CSV_Data_Issue_Report_Preview.gif

Working with the CSV Data Import Error Report

Filing Details in FYI

When the Error Report is created, a link will be displayed to download the file.

 A copy will also be created within FYI, based on the name of the original file. The Error Report will be called with "Invalid rows -" followed by the original filename, e.g. "Invalid rows - Jobs Import July 2025".

The document will be automatically filed using the same filing details as the original CSV import file:

  • Cabinet
  • Keywords
  • Work Type
  • Tags
  • Job
  • Categories

If Tags have been enabled for the Cabinet, the tag Exclude-From-Import will be added.

Understanding the Error Report

The Error Report will contain the columns from the original document, with only the rows that contained invalid data included in the file.

An additional column, Failure Reason(s), will be added at the end of the file, displaying the cause of the import error for each row. For example, a matching client could not be found, or the format of the data was incorrect. Refer to Troubleshooting Failure Reasons below.

4327_CSV_Import_Error_Report_CSV.gif

Correcting and Importing Updated Data

The Error Report is designed to allow you to easily fix the invalid data for each row. This can be done by either:

  • Updating the original file and running another test to check that the errors have been resolved before running the Automation process.
  • Using the Error Report to correct the invalid data only, if the Automation Process has already been run.
Updating the original CSV Import file

Updates to the original CSV Import file should be made where the initial import has not yet been performed, for example, if the Error Report was downloaded from the Automation Test window.

  1. Open the original CSV Import file for editing
     
  2. In the Excel toolbar, click Sort & Filter and Filter. This will enable the filters for each column within the file.
    4332_CSV_Import_Error_Report_Excel_Filter.gif
  3. In another window, open the Error Report (either the downloaded file or within FYI).
     
  4. For each row in the Error Report, review the Failure Reason(s) column to determine the adjustment required, for example, where the client could not be determined. Refer to Troubleshooting Failure Reasons below for information on resolving common errors.
    4327_CSV_Import_Error_Report_CSV.gif
  5. In the original CSV Import file, locate the row to be updated using the filters. For example, if the error reported that the Job Number column was empty, filter the Job Number column by "(Blanks)".
    4331_CSV_Import_Error_Report_Filter_Blank.gif
  6. Update the data as required, for example, by entering a valid Job Number.
     
  7. Continue to fix all reported errors as required.
     
  8. Finish editing the file, and ensure the changes are saved and filed in FYI.
     
  9. Open the Automation Process used to import the data.
     
  10. The Filter should only be edited if changes are required to the column Types, or the client and job matching options. Refer to Process Filter Details - CSV Data Import.
     
  11. Test the Automation to validate that the issues were resolved and that no further errors were detected. 
    Note: If further errors are detected, a new error report will be created. Repeat the steps above to correct the data.
     
  12. Once there are no errors remaining, run the automation to import the data.
Using the Error Report

To use the Error Report and upload the corrected data into FYI:

  1. Open the Error Report within FYI for editing.
     
  2. For each row, review the Failure Reason(s) column to determine the adjustment required, for example, where the client could not be determined. Refer to Troubleshooting Failure Reasons below for information on resolving common errors.
    4327_CSV_Import_Error_Report_CSV.gif
  3. Update each of the rows in the Error Report as required. For example, entering a valid Job Number. For information on populating the CSV file, refer to Automation Filter Details - CSV Data Import.
     
  4. Finish editing the file, ensuring the changes are saved and filed in FYI.
     
  5. Update or create a new Document View to ensure only the updated Error Report is displayed in the list.
    Note: When the Document View is selected in the CSV Data Import Automation Filter, the import will be run for all files displayed in the selected View. If both the original file and the Error Report are included, duplicate entries or additional Error Reports may be created.
     
  6. Open the Automation Process used to import the data.
     
  7. Edit the Filter, and select the updated Error Report from the Sample Document field. 
     
  8. Click Reset From CSV, and ensure all columns have the correct selected Type.
     
  9. Untick the FailureReasonS column, as the data is not required to be imported into FYI. 
     
  10. Ensure the Run Only Once option is enabled, to prevent creating duplicates in FYI if the process needs to be re-run. 
     
  11. Tick Match Clients During Validation and Match Jobs During Validation if updating existing clients and jobs in FYI, ensuring the columns have the relevant Type selected. For more information, refer to Process Filter Details - CSV Data Import.
    4328_CSV_Import_Error_Report_Filter_settings.gif
  12. Click Save.
     
  13. Test the Automation to validate that the issues were resolved and that no further errors were detected. 
    Note: If further errors are detected, a new error report will be created. Repeat the steps above to correct the data.
     
  14. Once there are no errors remaining, run the automation to import the data.

Troubleshooting Failure Reasons

Click on the headings below for troubleshooting information on error messages.

Unable to determine client or Unable to determine job

Issue

The Import Error Report displays one of the following errors in the Failure Reason(s) column:

  • All client fields (Column Type) empty, unable to determine client.
  • All job fields (Column Type) empty, unable to determine job.

For example, if the column Job Number was used to match the job, but was not populated for a row, the error would be displayed as:

  •  All job fields (Job Number) empty, unable to determine job.

Cause

The columns selected to be used for matching clients and/or jobs, displayed in brackets in the error, have not been populated, and a matching client cannot be found.

Solution

To resolve the error, update the CSV file with the relevant client details and reimport the file.

Source CSV contained invalid cells

Issue

When trying to import the CSV file, the Issue Report CSV file reports Invalid cells.

Cause

Invalid cells can be caused by:

  • Data format - The Data in the selected Column is not in the correct format. For example, selecting a Numerical Type column for a Date field, or a Date field being entered as "August".
     
  • The Client has been archived - The client must be restored before they can be updated using the Automation process. 

Solution

The data must be corrected in the original file or the Issue Report CSV before importing the file.

  • If using the original file, remove rows that were successfully imported to avoid creating duplicates during the next import.
     
  • If using the Issue Report file, for practices using the Tag functionality, you will need to remove the tag "Exclude-from-import" to ensure the Issue Report file can be used to re-import data. Files with this tag will not be able to be used.
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