Plan: Not Available: Intermediate Available: Pro or Elite
Users: Not Available: All users, User Group Permissions Available: FYI Admins
Practice Management Source: Not Available: APS, Iris, MYOB AE & AO, CCH, MYOB Practice Management (formerly GreatSoft) Available: FYI or Xero Practice Manager
Issue
For practices on the Pro plan and integrated with Xero Practice Manager (XPM), after submitting a Time entry in FYI, the following error displays in Practice Activity:
- "Error exporting time entry - Validation error"
Cause
This error occurs when trying to submit time to a period that has already been submitted or locked in XPM. Once a timesheet period is submitted in XPM, time entries can no longer be created for that period.
Solution
To fix the issue, first check if the timesheet period is locked in XPM.
Once confirmed, you can either:
-
Unlock the timesheet in XPM. Refer to the Xero help article: https://central.xero.com/s/article/Submit-time-sheets or,
- Change the date of the time entry in FYI to a period that is still open in XPM.
After making either of these changes, the time entry can be resubmitted from FYI.