Error "Job sync failed with Bad Request: Response generated is too large" in Practice Activity

Plan: Available: All plans 

Users: Available: All users

Practice Management Source: Available: All sources

Issue

For practices integrated with Xero Practice Manager (XPM) when synchronising jobs with FYI, the following error is displayed in Practice Activity:

  • Job sync failed with Bad Request: Response generated is too large.

Cause

This error occurs when there is too much information being sent from XPM to FYI during the job sync. This usually means:

  • There are too many active jobs in XPM. For example, jobs with a 'Standard' type.
  • Some jobs may include large notes or extra details. For example, entire emails are copied into job tasks.

When FYI attempts to synchronise all the job information, the volume of data associated with these jobs exceeds the limits allowed by the XPM API, and the import from XPM to FYI fails.

Solution

To resolve the issue, we recommend a clean-up process in both FYI and XPM:

  1. Clean Up Current Jobs in FYI: Review and archive or remove jobs that are no longer active or needed.
  2. Reduce Excessive Data in XPM: Review and tidy task data where appropriate. Avoid pasting large amounts of information (for example, full emails) in XPM task notes.

Once the clean-up is complete, an FYI Admin can run a manual Job sync with XPM, or await the Automatic Sync of Jobs overnight. 

In the interim, users will be able to sync individual jobs by clicking the Sync Job button on the Job - Summary tab. This will sync the standard job details and Custom Fields, where FYI as Primary is not enabled, for that particular job from XPM into FYI.

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