Features

Error FYI-2239: Error updating job state - Invalid task identifier

Issue

For practices integrated with Xero Practice Manager, when assigning a State to a Workflow Job in FYI, the following message displays in Practice Activity:

  • FYI-2239: Error updating job state - Invalid task identifier

Cause

XPM Workflow Jobs are created in FYI when a Task has been created in XPM against a job.

When this error is displayed, it means the Task in XPM that created the Workflow Job has since been deleted. The changes cannot be synced as the Job Task no longer exists in Xero Practice Manager.

Solution

If the Job is no longer required, In FYI set the State of the Job to "Cancelled". Otherwise, you will need to create a new job and task:

  1. Create a new Job and any Tasks in Xero Practice Manager.

  2. Run a manual sync with Xero Practice Manager, otherwise FYI will create the Job during the next automatic overnight sync.

  3. In FYI, set the required State on the new Job.

  4. Update the filing for any documents to be against the new Job.

  5. Check there are no outstanding Tasks for the old Job.

  6. Update the Job State in FYI for the previous job to be "Cancelled".
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