Why is a new or edited Client Custom Field in Xero Practice Manager not showing straight away in FYI?

Plan: Available: All plans

Users: Not Available: All users Available: FYI Admins or User Group Permissions

Practice Management Source: Not Available: APS, Iris, MYOB AE & AO, CCH, MYOB Practice Management (formerly GreatSoft) Available: FYI or Xero Practice Manager

Issue

I have set up a Client Custom Field in Xero Practice Manager, but it is not showing in FYI, even after a Manual Sync and the Sync from PM in the Client - Custom Fields tab.

Cause

The manual Sync and the Sync from PM in the Client - Custom Fields tab will sync changes to values only, and not changes to the Custom Field Definitions, including newly created Custom Fields.

Note: An FYI Admin can add a Client Custom Field in FYI, which will be available to use straight away. Refer to Creating Custom Fields.

Solution

Custom Field Definitions

The synchronisation frequency of Custom Field definitions will vary depending on your Practice Management settings. Refer to Synchronising Clients, Staff, Jobs, Time, Tax Returns with Xero Practice Manager and Xero Practice Manager automation app settings.

Custom Field Values

The timing of Custom Field value updates depends on your selected Practice Management Source

Refer to Synchronising Clients, Staff, Jobs, Time, Tax Returns with Xero Practice Manager for details on synchronisation frequency and settings.

Updates to Custom Field Values in XPM will be synchronised within approximately 15 minutes (if there are also changes to the Client Details), or overnight on Friday, Saturday, and Sunday nights. 

Note: Clients will be marked with a Pending Sync tag while waiting for the updates to be synced with Xero Practice Manager. This tag is located beside the Client Name in the Client Summary tab. When the Client is marked as Pending Sync, Custom Field changes made in XPM will not be synchronised.

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