Issue
I have set up a Client Custom Field in Xero Practice Manager, but it is not showing in FYI.
I have tried a Manual Sync and the Sync from PM in the Client - Custom Fields tab, but it is not available to select as a filter in FYI.
Cause
The manual Sync and the Sync from PM in the Client - Custom Fields tab will sync any changes to the values selected for a Custom Field, and not changes to the Custom Field Definitions, including newly created Custom Fields.
Solution
Custom Field Definitions
Changes to Custom Field Definitions in XPM are synchronised with FYI every 15 minutes, unless Sync Custom Fields from XPM is set to "Off" in the Xero Practice Manager automation app settings, in which case Custom Fields aren't synchronised at all.
Custom Field Values
The synchronisation of Custom Field Values will depend on your settings:
- For practices where FYI as Primary for Client Maintenance is enabled, Custom Field values are only synchronised one-way from FYI to Xero Practice Manager. Changes to XPM will not be applied to Clients in FYI.
Note: When a new client is created in Xero Practice Manager, Client Custom Field values will be synchronised to fYI as a one-time synchronisation only.
- For practices where FYI as Primary for Client Maintenance is not enabled, updates to Custom Field Values in XPM will be synchronised within 15 minutes. If Sync Custom Fields from XPM is set to "Off" in the Xero Practice Manager automation app settings, Custom Fields won't be synchronised at all.
Note: Clients will be marked with a Pending Sync tag while waiting for the updates to be synced with Xero Practice Manager. This tag is located beside the Client Name in the Client Summary tab. When the Client is marked as Pending Sync, Custom Field changes made in XPM will not be synchronised.
Note: An FYI Admin can add a Client Custom Field in FYI, which will be available to use straight away. Refer to Managing Custom Fields.