Error "Invalid Job Identifier" when updating jobs

Plan: Available: All plans

Users: Available: All users

Practice Management Source: Not Available: APS, Iris, MYOB AE & AO, CCH, MYOB Practice Management (formerly GreatSoft) Available: FYI or Xero Practice Manager

Issue

When updating a job in FYI, for example, to assign a Job to a Partner or Manager, one of the following messages is displayed:

  • FYI-2237: Error updating job details - Invalid job identifier

Cause

For practices integrated with Xero Practice Manager, the Job has been deleted in Xero Practice Manager. FYI is unable to sync the changes, and has automatically cancelled the job in FYI to prevent further unnecessary syncs. 

Solution

You will need to create a new job and transfer any required data from the cancelled job, including documents, comments, and tasks.

  1. Create a new job in Xero Practice Manager.
     
  2. Run a manual sync of Jobs in FYI. 
     
  3. Open the new Job in FYI.
     
  4. Update the filing for any documents to be against the new Job.
     
  5. Manually copy all the comments to the new Job from the cancelled job. Review the Job - Comments tab for a list of comments associated with the job.
     
  6. Update the tasks associated with the cancelled job to be assigned to the new job.
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