Issue
When Practice Sync performs a scheduled synchronisation, the following error is displayed in Practice Activity:
- (User email address) removed from local Practice Sync cache. Practice sync will automatically attempt to recreate the user in the next scheduled sync.
Cause
The Practice Sync cache is used to temporarily store data during the synchronisation, allowing for more efficient synchronisation of data to FYI.
The error reported in Practice Activity can be caused by:
- User Not Found - If the user was not found in FYI, but a previous entry exists in the cache.
- Invalid Data - If the user data was invalid or incomplete, for example, an invalid email or missing Display Name.
- Synchronisation issues - where sync issues are detected between the local cache and the FYI system.
- Manual deletion - The user has been manually deleted from the FYI system or another source.
- Exception handling - If an error occurs trying to update the user, Practice Sync will log the error and then remove the user from the cache to allow the remainder of the sync to continue successfully.
Solution
Practice Sync will automatically attempt to update the user during the next scheduled sync.
If the error continues to be displayed, or the user has not been synchronised, please contact support.