FYI is automatically creating blank Client Phone Records
Issue
When visiting the Client - Summary tab on the Client Workspace, FYI automatically creates a Phone Record, and displays the Phone Editor drawer.
Cause
This is typically caused by browser extensions automatically populating fields on the page, triggering a new Phone Record, for example, the LastPass browser extension.
Solution
You will need to edit your Browser Extension settings to resolve the issue. This could be done by:
Disabling Autofill, so that fields aren't automatically populated by the extension. For example, LastPass allows users to disable the Autofill feature per site, so could be disabled for FYI while retaining the feature for other websites.
Disabling the browser extension entirely. Click on the link for the relevant browser below.