Issue
When synchronising FYI with APS via Practice Sync, one of the following error messages is displayed in Practice Activity:
- Unable to find Custom Fields that match Custom Attributes.
- FYI-2261 "Create new Client Custom Fields in FYI with the same Name and Type as the APS Custom Attribute."
Cause
APS is trying to synchronise Custom Attributes with FYI, but is unable to find a matching Custom Field in FYI.
To synchronise Custom Attribute Fields, you must first create a matching Custom Field in FYI with the same Name and Type (the synchronisation is case-sensitive).
Solution
You will need to review your Custom Attributes in APS to determine which Custom Fields will need to be created in FYI.
Note: Custom Fields must be created using the appropriate Type to successfully sync with APS Custom Attributes. Refer to the APS PM Toolkit to confirm the Type for each Custom Attribute. For information on setting up Custom Fields in FYI, refer to Managing Custom Fields.
The APS Custom Attribute Types are displayed below, with their equivalent Field Type in FYI.
APS Field Type | FYI Custom Field Type |
$ value | Decimal |
Address | Text |
Combo | Drop-down |
Date | Date |
Discrete list attribute ex SQL | Drop-down |
Integer or Long Integer | Number |
Multi-Line Text Attribute | Text |
Password | Text |
Percentage | Decimal |
Single or Double | Number |
Text Attribute | Text |
Text String | Text |
TextLists | Drop-down |
True/False | Checkbox |
Year | Number |