Issue
When synchronising clients from an integrated Practice Management system using Practice Sync, for example, IRIS, the following error is displayed in Practice Activity:
- Error when syncing (client name) to FYI. The entity appears to have been deleted.
Cause
The client was previously synchronised to FYI but has since been removed, for example, as part of a data cleanup where the Client Type is not compatible with Practice Sync. The client still remains in the Practice Sync cache, and needs to be cleared.
Solution
You will need to archive the client in your practice management solution, then flush the cache for the relevant Practice Sync automation app in FYI.
The example below shows how to flush the cache using the IRIS app.
- In FYI, click the Automation menu option.
- Click the Apps tab.
- Locate the Practice Sync IRIS app and click the Settings cog icon.
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Click the Flush Cache button. The cache will be flushed during the next synchronisation.
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A message will briefly display to confirm your request, and the "Flush Cache" button will be inactive until the cache flush has been completed.