Error "Sync failed with error" displayed in Practice Activity

Issue

For practices integrated with APS, synchronised fields such as Custom fields appear not to sync and the following error is displayed in Practice Activity:

  • Sync failed with error : String 'MM/DD/YYYY 11:32:37 AM' was not recognized as a valid DateTime."

Cause

The machine where the Practice Sync is installed is set to an unsupported date format, which is causing the synchronisation with APS to error. The MM/DD/YYYY format specifically is not a supported date format.

Solution

Ensure that the machine date settings are changed to a supported date format eg DD/MM/YYYY.

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