Error FYI-2236 or FYI-2241 "Due Date cannot be before the Start Date"

Issue

When trying to create or update a job, either from an Automation process or Bulk Update, one of the following errors is displayed in Practice Activity:

  • The due date cannot be before the start date.
  • Due date must be on or after the Start date. Due date has been set to Start Date.

Cause

A job cannot be set to a due date before the job has started. For example, if a Job Start Date is set to the 1st of October 2024, the due date cannot be set to the 25th of September 2024.

Solution

When running an Automation process, the error will be reported but the Due Date will be automatically updated to match the Start Date to allow the process to continue.

If performing a Bulk Update, the user will need to manually select a valid date.

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