Features

Error FYI-2234: Error exporting job state - Invalid state code

Issue

For practices integrated with Xero Practice Manager, when I change the Job State in the Update Job drawer FYI, the following error is displayed in Practice Activity:

  • Error exporting job state - Invalid state code.

Cause

This issue can be caused by the following:

  • The Job State has been deleted in Xero Practice Manager, but is still available in FYI.
  • The Job State's name has been changed in Xero Practice Manager and the change has not yet synced to FYI.

Solution

  1. Compare FYI with Xero Practice Manager to confirm if the Job State exists in XPM, and the name is the same. 

  2. If the Job State has been deleted from Xero Practice Manager, the Job State should be archived in FYI. 

  3. If the name of the Job State has changed, run a manual sync of Jobs to update the change to FYI. This can be done by any user with the Sync function on the Jobs list.

  4. Once the synchronisation has been completed, update the Job in FYI to select the Job State.

Refer also to Renaming a Job State in Xero Practice Manager and Deleting a Job State in Xero Practice Manager in Job States.

Was this article helpful?
0 out of 0 found this helpful