Error FYI-2234: Error exporting job state - Invalid state code
Issue
For practices integrated with Xero Practice Manager, when I change the Job State in the Update Job drawer FYI, the following error is displayed in Practice Activity:
Error exporting job state - Invalid state code.
Cause
This issue can be caused by the following:
The Job State has been deleted in Xero Practice Manager, but is still available in FYI.
The Job State's name has been changed in Xero Practice Manager and the change has not yet synced to FYI.
Solution
Compare FYI with Xero Practice Manager to confirm if the Job State exists in XPM, and the name is the same.
If the Job State has been deleted from Xero Practice Manager, the Job State should be archived in FYI.
If the name of the Job State has changed, run a manual sync of Jobs to create the new Job State in FYI. This can be done by any user with the Sync function on the Jobs list.
Once the new Job State has been created in FYI, update the Job in FYI to select the Job State.
Refer also to Renaming a Job State and Deleting a Job State in Job States Overview.