Error "Selected user account does not exist in tenant" when trying to login to New Collaborate

Plan: Not Available: Intermediate Available: Pro or Elite

Users: Not Available: All users Available: FYI Admins or User Group permissions

Practice Management Source: Available: All sources

Issue

When logging into the New Collaborate site, the following error is displayed:

  • "Selected user account does not exist in tenant (Tenant Name) and cannot access the application (application ID) in that tenant. The account needs to be added as an external user in the tenant first.

Cause

This error occurs when a client is trying to log in to New Collaborate with an email address that does not exist in the Microsoft Entra guest user list.

Solution

Run the Client Sharing Settings Status Check in FYI to ensure there are no issues.  Refer to section Client Sharing Settings Status Check in Troubleshooting New Collaborate using Status Check.

After running the Client Sharing Settings Status Check, if no issues are identified:

  • Confirm the client is trying to log in with the email address that the invitation was sent to
  • Ask the client to attempt to log in using an incognito or private browser. This will ensure that the browser is not trying to log in with a cached login from a different account.

If the client wishes to use a different email to log in, you will need to:

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