Features

Error "Unable to update the Client Share Folder as the Name already exists" when renaming a New Collaborate Share Folder

Issue

When trying to rename the Client Share Folder on New Collaborate, as the client's name has changed, the following error is displayed:

  • Unable to update the Client share folder name as another folder of the same name already exists. Remove the conflicting folder and try again.

Cause

After the client was renamed, the New Collaborate folder was unable to be renamed by clicking "Fix It" on the Client - Collaborate tab. Refer to Renaming a Client with New Collaborate Shared Folder and Files.

This is typically caused by another folder with the new name on the New Collaborate site.

After the client's name was updated, but before it was renamed, new documents were shared, creating the folder with the new client name. As duplicate folder names are not permitted, the old folder cannot automatically be updated to match the new name.

Solution

To resolve the issue, you will need to remove the conflicting folder, create a new folder from FYI, and then re-share the documents.

Step 1 - Delete the Sharing Settings in FYI

This step will remove the client folder with the old name from the New Collaborate SharePoint site.

  1. In FYI, navigate to the Client - Collaborate tab.

  2. Make a note of the users currently displayed on the Sharing Settings window. You will need to re-add these users in a later step.

  3. Click Delete Sharing.
    3224_Collaborate_Delete_Sharing_button.gif
  4. Wait for the Folder Deletion process to complete, please note, this can take up to 15 minutes.

  5. Close the Sharing Settings window, and click the Refresh button on the browser to refresh FYI.
    3491_New_Collaborate_Browser_Refresh.gif

Step 2  - Delete the conflicting folder

  1. Tick the Client Folder with the new client name

  2. Click Delete.
    If the Delete option is not available, you have not logged into the SharePoint folder with the OneDrive Admin User account.

    Important: Ensure you do not delete the folder with the old Client Name. This folder will be removed when deleting the Sharing Settings later in the process.
    3490_New_Collaborate_SharePoint_Delete_Folder.gif

If the wrong folder is deleted by mistake, the folder can be restored from the SharePoint Recycle Bin. Refer to the Microsoft article Restore items in the recycle bin that were deleted from SharePoint or Teams.

Step 3 - Add users to Sharing Settings

  1. Open the Sharing Settings window.

  2. Click Give user access. Add all users previously displayed on the Sharing Settings window, as per Step 3 above. This will create a Share folder on the New Collaborate site with the new Client Name.
    Refer to Sharing the Share Folder and Upload Folder with Clients
    1038_Share_folder_user_access.gif

Step 4 - Reshare the Documents and Email Updated Links

Documents can be bulk shared to re-upload the files to the New Collaborate SharePoint. Use the Share No Email option to share the documents first, before emailing the client.

  1. The Client - Collaborate tab displays a list of documents that were historically shared using New Collaborate.

  2. Tick the documents to be shared.

  3. Click Share and select Share No Email
    For detailed instructions, refer to Sharing Documents with Clientsit's 
    2796_Share_No_Email_Documents_List.gif
  4. Send an email to the users on the Share Folder settings by sending the Collaborate Invitation Template, or by sending the folder links manually. Refer to Sharing the Share Folder and Upload Folder with Clients and Resending the Folder Links Manually
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