Plan: Not Available: Intermediate Available: Pro or Elite
Users: Not Available: All users, User Group Permissions Available: FYI Admins
Practice Management Source: Available: All sources
Issue
When running a New Collaborate Status Check, the following error is displayed:
- The Practice OneDrive Admin user is not a Site Owner of the Collaborate SharePoint site.
Cause
This issue typically occurs when either:
- A new OneDrive Admin User has been selected in FYI, but has not been applied as an owner of the SharePoint site on Microsoft 365, or
- OneDrive Admin’s primary email address in User Settings does not match their Microsoft 365 email address. When FYI checks permissions, it uses the main email address in their User profile, not an alias, which can result in this error if these addresses differ.
Solution
To manually add the user as an Admin/Owner of the SharePoint site:
- Log in to admin.microsoft.com.
- Navigate to Show All > SharePoint.
- From the menu on the left, click Active Sites.
- Select your SharePoint site and navigate to Permissions > Site Admins - Manage.
-
Add the required user as an admin.
Note: Ensure the user has been configured on Microsoft 365 with the correct permissions required for New Collaborate, including Guest Invite, and User Administrator (optional).
-
Save the changes.
- Re-run the New Collaborate Status Check to confirm the issue has been resolved.
To update the OneDrive Admin's primary email address:
- Update the user's email address in the relevant practice management system to ensure their primary email address matches their Microsoft 365 email. Users will need to wait for the next sync to run before the details are updated in FYI. Refer to Managing Users for more information.
- Re-run the New Collaborate Status Check to confirm the issue has been resolved.