Issue
An invoice has been created, but hasn't been synchronised to Xero. The following error is displayed in Practice Activity:
- Error exporting invoice - Skipped sending invoice to Xero, no tenant set for Job Template
Cause
The Job associated with the Invoice does not have a Job Template set.
Job Templates are responsible for the Chart of Accounts selected when costs are synchronised to Xero. Without a Job Template, an account is not defined, and the invoice will not be synchronised.
Solution
To resolve the issue:
- Update the Job to select a Job Template. Refer to Apply FYI Job Templates to Jobs.
- Resubmit the invoice using Practice Activity. Refer to Practice Activity.