Issue
A client has been updated with a new Tax Number (either a TFN or IRD depending on your location), however the changes have not been synchronised to Xero Practice Manager and the following error is displayed in Practice Activity:
- The Client Tax Number either has an invalid format or already exists in Xero Practice Manager.
Cause
This error can be caused by either:
- A number was entered in an invalid format that doesn't match the requirement of Xero for the TFN/IRD field.
- The number already exists in Xero. Xero Practice Manager does not allow for multiple different entities to use the same Tax Number.
If the changes failed to sync due to either of the causes above, the Tax Number field in FYI will be reverted to the value stored in XPM in the next sync.
Solution
You will need to enter a unique TFN/IRD into FYI using the correct format:
- A TFN is a 9-digit number in the format of xxx xxx xxx.
- An IRD is an eight or nine digit number in the format 99999999 or 999999999 (depending on when it was first issued).