Features

Error FYI-2169 "The Client Tax Number either has an invalid format or already exists in Xero Practice Manager"

Issue

A client has been updated with a new Tax Number (either a TFN or IRD depending on your location), however the changes have not been synchronised to Xero Practice Manager and the following error is displayed in Practice Activity:

  • The Client Tax Number either has an invalid format or already exists in Xero Practice Manager.

Cause

This error can be caused by either:

  • A number was entered in an invalid format that doesn't match the requirement of Xero for the TFN/IRD field.
  • The number already exists in Xero. Xero Practice Manager does not allow for multiple different entities to use the same Tax Number.

When updating a client in FYI with a new Tax Number, FYI will try to synchronise the update to Xero. If the changes cannot be applied, the error will be displayed in Practice Activity, and during the next synchronisation, the client's Tax Number will be reverted to the previous value stored in Xero Practice Manager.

Solution

You will need to enter a unique TFN/IRD into FYI using the correct format.

  • A TFN is a 9-digit number in the format of xxx xxx xxx.
  • An IRD is an eight or nine digit number in the format 99999999 or 999999999 (depending
    on when it was first issued).
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