Issue
When syncing users to FYI from Xero Practice Manager the following error is displayed in Practice Activity:
- Some staff could not be synced from XPM as they have been added to another FYI practice.
Cause
The user's email address is already associated with an FYI practice. Users cannot belong to multiple FYI practices.
Solution
As new users are added to Xero Practice Manager, they will be synchronised and created in FYI. The actions you take to resolve the issue depends on whether these users are required in FYI or not.
If the user account is not required in FYI
There may be times where a user account has been created in XPM, but is not required in FYI, for example, standard Xero email addresses.
You will need to remove the account from Xero Practice Manager. Refer to the Xero article Remove staff from your practice
If the user account is required
If the user account is required, it will need to be removed from the first practice before it can be synchronised and created in the new one.
Note: If you cannot find the user or don't have access to the practice where the user already exists please contact our Support team
To remove the user from the practice:
- Ensure all steps have been completed in Steps to Complete before Offboarding a Team Member or Making a User Inactive
- Log into the practice where the user should be removed from.
- Navigate to Settings - Practice Settings - General - Users.
- Click on the required user in the list.
- Set Active to Off.
Refer to Managing Users.
Contact our Support team with a request to delete the user. Once that has been done, the user can be synchronised and created in the new practice.