Error "Skipped jobs older than 24 months due to low Xero request quota"

Plan: Available: All plans

Users: Not Available: All users Available: FYI Admins or User Group Permissions

Practice Management Source: Not Available: APS, Iris, MYOB AE & AO, CCH, MYOB Practice Management (formerly GreatSoft) Available: FYI or Xero Practice Manager

Issue

When synchronising jobs with Xero Practice Manager, the sync doesn't complete and an alert is added to Practice Activity:

  • Skipped jobs older than 24 months due to low Xero request quota

Cause

Xero uses rate-limiting, meaning there is a set amount of requests that can be made each day to synchronise data between FYI and Xero Practice Manager.

When synchronising jobs older than 24 months, FYI uses a request to check the status of the job to confirm if it has been deleted or there has been a change to the Job State. If there is only a small number of remaining requests available, FYI will cancel the synchronisation to reserve those requests for higher priority requests.

Solution

When more requests become available, you can prompt a manual sync, or alternatively, wait for the next overnight synchronisation.

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