Error FYI-2129 "We could not completely remove the guest user." in New Collaborate Sharing Settings

Plan: Not Available: Intermediate Available: Pro or Elite

Users: Not Available: All users, User Group Permissions Available: FYI Admins

Practice Management Source: Available: All sources

Issue

When trying to delete a user from the New Collaborate Sharing Settings, the following error is displayed:

  • We could not completely remove the guest user. Please ask an administrator to manually delete the user from the Microsoft Entra Admin Centre.

Cause

The OneDrive Admin account does not have the "User Administrator" role applied. As a result, the user was able to successfully be removed from the New Collaborate SharePoint site, but not from Microsoft 365.

Solution

Consider whether it is appropriate to update your practice OneDrive user permissions to allow for the deletion of guest users, refer to Step 3 in Setting up Microsoft 365 for New Collaborate.

Alternatively, a user with access to the Microsoft Entra Admin Centre will need to manually remove the user. Refer to the Microsoft article Add or delete users


 

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