Features

Why are my clients losing access to their folder on the New Collaborate Sharepoint site after a period of time?

Issue

I have added clients to my New Collaborate site, and they were able to successfully access the files. However, after some time they lose access to the site. They're are not displayed in the Sharing Settings in FYI, but our team didn't remove them.

Why can't they access the client folder anymore?

Cause

A setting has been enabled in the SharePoint Admin Centre which expires Guest Access to the site after the selected number of days.

Solution

To resolve the issue, you will need to:

1 - Re-add the Clients to Sharing Settings

  1. Re-add the clients to the Sharing Settings in FYI. Refer to Sharing Documents with Clients and External Users.

  2. Update the SharePoint Admin Centre to disable the auto-expiry setting.

2 - Update Expiration Settings in SharePoint Admin Centre

To update the setting in the SharePoint Admin Centre:

  1. Open Microsoft 365 Admin Center by visiting https://admin.microsoft.com/.

  2. Log in using a Microsoft Global Admin account.

  3. From the menu on the left-hand side, locate the Admin Centers section and select SharePoint (you may need to first click Show All). 

  4. From the menu on the left-hand side, select Policies, then select Sharing.

  5. In the section More external sharing settings untick the option "Guest access to a site or OneDrive will expire automatically after this many days".
    3208_Microsoft_Admin_Centre_Guest_Access_Expiry.gif
  6. If the site has the “Same as Organisation-level setting" setting ticked, untick the option and change the setting to "Guest access doesn’t expire automatically".

  7. Click Save.

For more information refer to the Microsoft article Manage sharing settings for SharePoint and OneDrive in Microsoft 365.

3 - Check and clear the expiration flag in New Collaborate site

You will need to check if any remaining guest users still have an expiration date and clear this from your Collaborate SharePoint site. To remove any remaining expiration dates:

  1. Login to your New Collaborate SharePoint site.

  2. Open Settings by clicking the clog icon in the top right hand corner.

  3. Click Site Permissions.
  4. Click Manage under Guest Expiration.

  5. If there are any guest user accounts with a pending expiration, their details will be listed with their Name, Email and Expiration Date.

  6. Select the relevant name/s to clear their expiration.
    A tick icon will appear to indicate the name/s selected.

  7. Click Clear expiration

 

 

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