FYI-2150 "OneDrive synchronisation failed with an authorisation error"

Issue

Practice Activity displays one of the following errors:

  • OneDrive failed to sync due to authorisation error.
  • OneDrive Admin (user name) disconnected. Please login to FYI as your OneDrive admin.
  • FYI-2150 OneDrive failed to sync due to authorisation error.

Cause

The OneDrive Admin credentials or refresh token has expired, typically caused if the user has not logged into FYI for some time.

Solution

You will need to log into FYI using the OneDrive Admin account to verify their identity and refresh the token. The OneDrive synchronisation should then resume successfully. 

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