Issue
When signing into FYI or the FYI Office add-ins (Outlook and Office), the below message displays:
- Need admin approval
Cause
The application has not been granted permission by a Microsoft 365 Administrator in Microsoft Entra, or recent changes to the User Consent settings by Microsoft have resulted in new users receiving the 'Need Admin approval' message when logging in.
These changes to User Consent settings have been rolled out throughout July-August 2025, and affect practices previously using the default User Consent settings in Microsoft Entra. New users added to the tenant following these changes may receive the 'Need admin approval' message, even when their permissions are the same as other users, or when a Microsoft Global Admin has selected "Grant admin request for (your organisation)".
Note: Application permissions are set within the Microsoft tenant and are not controlled or administered by FYI. Practices will need their IT team to assist with this.
Solution
A Microsoft 365 admin will need to grant permission by:
- Select "Have an admin account? Sign in with that account" when the message displays.
- Sign in with the Microsoft 365 admin account.
- Ensure that "Consent on behalf of the organisation" is ticked.
Important note: The above steps will also need to be taken for all FYI Office add-ins including FYI for Office and FYI for Outlook.
If the "Need Admin approval" message continues to display, your IT provider will need to review Microsoft's recent User Consent settings changes and determine whether the "Allow user consent for apps from verified publishers, for selected permissions" setting in Entra can be used.
If the issue continues, we recommend contacting Microsoft Support for further assistance, as FYI do not control tenant policies and settings.