Features

When adding a user, they see a message "Approval required". How do I approve this?

Issue

I am adding a new user to FYI Docs and I have created the user and sent an invitation. When the user accepts the invitation the below message displays that they need admin approval. I am an admin user. How do I approve this?

5010_Approval_Required.gif

Should the message display "Need admin approval" refer to When signing into the FYI Add-in, a message displays "Need admin approval". How do I approve this?

Causes

This could be caused by one of the following. See below for the solution for each of these.

You are an admin in Entra but not in FYI

If you are an admin in Entra, but not in FYI, your IT administrator may need to provide consent.

Solution
Refer to the Microsoft help article Review admin consent requests.

  1. Sign in to the Microsoft Entra admin center.
  2. From the menu on the left, navigate to Identity - Applications - Enterprise applications.
  3. Under Activity, select Admin consent requests.
  4. Select the application that is being requested.
  5. Review details about the request:
    • To see who is requesting access and why, select the Requested by tab.
    • To see what permissions are being requested by the application, select Review permissions and consent.
  6. Evaluate the request and take the appropriate action.
  7. Ask the user to try to access FYI.

Entra is expiring the consent request

If a user receives the approval required banner again after a number of days, the consent request may be set to expire due to the admin consent workflow.

Solution
For information on how to configure this, refer to the Microsoft help article Configure the admin consent workflow.

Your IT department could alternatively grant Microsoft 365 tenant-wide consent for FYI. Refer to the Microsoft help article Grant tenant-wide admin consent to an application

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