Features

Error "The invoice is not attached - PDF is unavailable" when emailing an invoice using an Automation Process

Issue

When using an Automation Process to send an email with an invoice or credit note attached, the process completes, but the following warning is displayed:

  • The invoice is not attached - PDF is unavailable
  • The email is saved as a draft.

Cause

The invoice or credit note has not yet generated a PDF document in FYI, so there is no document available to attach.

PDF documents for invoices are only created for invoices and credit notes once it has been assigned an invoice number or credit note number, and the Preview tab is available in the Invoice Drawer.

Solution

You will need to approve the invoice to create the PDF used as an attachment. Refer to Approving Invoices

Please note that it's recommended to set up a dedicated Invoice view, filtered by Invoice Status and any other relevant criteria, to ensure only invoices that are ready to send are included in the Automation Process step.

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