Issue
When using Zapier to create jobs or clients in FYI, when the Zapier process is activated, not all the data was updated in FYI.
For example, where there is a Workflow job creation step in Zapier, instead of creating workflow jobs for multiple clients, the process only created one job for one client in FYI.
Cause
It is likely that the Zap process executed each step too quickly, not allowing enough time for newly created data to be retrieved by FYI.
Solution
Add a Delay step to the Zapier process. This step adds a short delay to the process steps, allowing data to be fully available for FYI to retrieve the details and avoid synchronisation issues.
The Delay should be added after the step that generates new data in FYI that may require additional time to be processed.
To create a Delay by Zapier step:
- Login to Zapier and locate the required Zap process.
- Click the + button to add a new step.
- Select the app Delay by Zapier.
- Select the Delay For from the Action event drop-down.
- Click Continue.
- Enter a value in the Time Delayed For (value) section.
- Select a unit from the Time Delayed For (unit) drop-down.
Note: A minimum 6-minute delay is recommended. However, the time delay entered will depend on the time needed for the previous task to be fully completed before the next one starts. - Click Continue and follow the prompts to test the step.