Features

Error calling foundry: Request failed with status code 500, 502, or 504 when running an Automation Process

Issue

When running an Automation Process, we are getting an error similar to the following

  • "Error calling foundry: Request failed with status code 500"
  • "Error calling foundry: Request failed with status code 502"
  • "Error calling foundry: Request failed with status code 504."

Cause

This may be caused by one of the following reasons:

  • If creating an Excel Spreadsheet, the file has been configured to use Merge Fields, but the Merge Names option is toggled on in FYI instead, or vice versa.
  • A temporary issue with Microsoft Graph API.
  • Exceeding the Microsoft Graph API Throttle Limits of 150MB per mailbox within 5mins.

Solution

The issue can be resolved by the following methods:

Update the Spreadsheet Template

Merging data from FYI into a spreadsheet can be done in one of two ways:

If your document has been set up to use Merge Fields, but in FYI has been enabled for Merge Names, an error will be displayed when creating the document. You will need to update the configuration in FYI to ensure the correct Merge option is selected.

  1. In FYI, click the Knowledge menu.

  2. Click the Template to open the Spreadsheet drawer.

  3. Expand the Filing section.

  4. Check the settings for the Merge Fields and Merge Names options, and update as required.
    Note: Only one of these should be toggled on at one time; enabling both will result in an error when generating the document.
    3143_Spreadsheet_Drawer_Merge_Fields.gif
  5. Re-try creating the document.

Re-run the Automation

Re-run the FYI Automation as follows:

  1. Navigate to the Process History (refer to Automation History).

  2. Filter the Status column to “Error”.

  3. Select the process(es) that have failed.
    Note: If you still encounter the error, try selecting the processes in batches, for example 50 at a time.

  4. Click the Retry button in the toolbar at the top.
    2450 Process History Retry.gif
  5. The automation will run again from the last failed step of the process.

Reduce the size of the email, including attachments

Microsoft Graph API has Throttle Limits of 150MB per mailbox in 5mins. This includes the content of the email, plus any attachments. For example, sending 51 clients an email with a 3MB attachment will exceed the limit and display the error. 

If the attachments are PDF files, there are a number of ways the file size can be reduced:

  • Using PDF software to compress the file. For example, refer to this guide when using Adobe PDF.
  • Using an online PDF Compressor, for example, Adobe's online PDF compression tool. Please bear in mind the sensitivity of any documents being uploaded, and refer to Adobe's Terms and Conditions before proceeding.
  • Using Microsoft Print to PDF to print the PDF as a new file. When selecting a printer, you will have the option to save the file as a PDF. Note that this may not reduce the file size much, in which case you may need to edit the file in PDF editing software, like Adobe PDF. Click here for instructions on installing Microsoft Print-to-PDF if not already available on your computer.

Once the file size has been reduced, delete any emails that have not been sent, then retry using the resized attachment.

If you are still receiving the error, please contact FYI support.

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